I am having trouble using Photoshop Brushes IN Photoshop

Most of the time the brushes on the site will install and work without any issues. 

However, from time to time we hear from people who get error messages when trying to install them or they simply can't get them to perform as expected

PLEASE NOTE: All brushes have been tested and are confirmed to work with all recent versions of Adobe Photoshop. We officially support CS6 & later but most brushes will work all the way back to CS3.

Photoshop Elements is a slightly different case. We do not test for Photoshop Elements performance. However, we have heard from many customers that they work perfectly fine in elements as well.

-----

Getting & Error Message on Install?

If you are getting an error message when installing the brushes. Please try the following:

  • Step 1.) Make SURE you have unzipped the files. 
  • Step 2.) Quit Photoshop & Re-open it.
  • Step 3.) Try installing them again.

In our experience following the above steps will allow the brushes to be properly installed in 99% of cases.

Please read our Brush Install Guide for additional info. 

If you still get any errors please CONTACT SUPPORT

-----

I've installed the brushes but they are not working properly?

If you have installed the brushes but are having issues with their performance here are some common problems & solutions:

 

=============================================
Symptom #1 Brushes don't rotate or follow my stylus.
============================================= 

This can be caused by a few different things. Here are a few things to try:

  • Quit Photoshop & Re-open it. Is the Problem fixed?
  • If not please try deleting the brushes installing them again. Fixed?
  • No? Ok Please check your settings in Photoshop. 

If you look at the top of the screen in PS you have most likely accidentally unchecked the icons shown below:

Please make sure they are checked.

If none of those fix the issue it could possibly be a problem with you tablet/pen display driver. Please make sure that the issue is not with that. 

If you still have questions please CONTACT SUPPORT


=============================================
Symptom #2 Brushes don't look right or make "thick" marks.
=============================================

  • Please check your settings in Photoshop. 

If you look at the top of the screen in PS you have most likely accidentally unchecked the icons shown below:


Please make sure they are checked.

 

=============================================
Symptom #3 Brushes are slow or lag or jitter.
============================================= 

This can be caused by a few different things. Here are a few things to try:

  • Quit Photoshop & Re-open it. Is the Problem fixed?
  • If not please try closing all other programs. Fixed?
  • No? Ok your computer or device is likely having a hard time keeping up. Try decreasing the image size or dpi 


If you still have questions please CONTACT SUPPORT

 

-------

Last Updated: 10/30/2018